Semiologic Pro for WordPress 3.8 is a go

I have released all the Semiologic WordPress plugins and the Semiologic Reloaded Theme that have been tested with WordPress 3.8.   For those with a valid membership simply upgrade from your WordPress dashboard.

To upgrade:

  1. As with any upgrading it is always advisable to backup your site and database just as a precaution.
  2. I recommend upgrading to the latest Version Checker plugin first.
  3. Next Update your plugins
  4. Update the Semiologic Reloaded theme
  5. Upgrade to WordPress 3.8.
  6. Install and activate the TinyMCE Advanced plugin.  You can use the WordPress Plugins->Add New to search for  the plugin. (more below)

I didn't want to hold up people from getting from WP 3.6 to 3.8 so a majority of the releases are simply tested releases.  If a version number is N.N.1 (or another 3rd digit) no new functionality was added.    Any plugin that has a new 2nd digit has either bug fixes or some features added.

In regards to the TinyMCE Advanced plugin, previously we bundled a bunch of useful add-ons to WordPress' TinyMCE editor and auto-configured them in the toolbar.   With these add-ons needing to keep track with TinyMCE updates in each WP release, bundling the appropriate add-ons is becoming a pain.   We'll revert back to the pre-sem-reloaded days where TinyMCE Advanced was included as a separate addon.

Thanks for the patience.  Go ahead and upgrade your sites to WP 3.8.